PHP – aktuell und in Zukunft

PHP ist eine weit verbreitete Web-Skriptsprache für die Erstellung dynamischer Webseiten. Viele beliebte Web-Anwendungen wie z.B. Blog/CMS (WordPress, Joomla, Typo3 etc.), Foren oder Shop-Systeme basieren auf PHP.

Um für die verschiedenen CMS- und Shopsysteme in Ihren verschiedenen Versionen die größtmögliche Kompatibilität zu erreichen, stehen unseren Kunden direkt mehrere PHP-Versionen zur Auswahl:

^ PHP-Version ^ SSD-Server ^ HDD-Server ^
^ 7.4 | {{fa>check-circle}} | {{fa>check-circle}} |
^ 7.3 | {{fa>check-circle}} | {{fa>check-circle}} |
^ 7.2 | {{fa>check-circle}} | {{fa>check-circle}} |
^ 7.1 | {{fa>check-circle}} | {{fa>check-circle}} |
^ 7.0 | {{fa>check-circle}} | {{fa>check-circle}} |
^ 5.6 | {{fa>check-circle}} | {{fa>check-circle}} |

Grundsätzlich empfehlen wir die Verwendung der jeweils aktuellsten PHP-Version.

Die vorher verfügbaren PHP-Versionen “5.3“ und “5.4“ sind seit einiger Zeit veraltet. Dies bedeutet, dass seitens des Herstellers eine Weiterentwicklung (z.B. für Sicherheitsupdates) nicht mehr stattfindet und auch der Support dafür eingestellt wurde. Die Sicherheit der Accounts ist bei Nutzung dieser stark veralteten PHP-Versionen also nicht mehr gewährleistet.

Aus diesem Grund unterstützen auch wir diese PHP-Versionen seit dem 01.01.2019 nicht mehr!

Wie kann ich herausfinden, welche PHP-Version ich derzeit verwende?

Über Ihr Kundeninterface haben Sie die Möglichkeit, für jede Domain bzw. Subdomain die verwendete PHP-Version individuell zu hinterlegen.

Sofern Sie die PHP-Version 5.6 oder höher verwenden, besteht für Sie zunächst kein Handlungsbedarf. Wir empfehlen allerdings die Umstellung auf die möglichst höchste PHP Version, da voraussichtlich Anfang 2020 auch der Support für PHP 5.6 eingestellt wird. Dazu werden wir Sie jedoch rechtzeitig informieren.

Meine Webseite arbeitet mit PHP 5.3 oder 5.4. Wie kann ich prüfen, ob sie auch mit einer neueren PHP-Version funktioniert?

Erfragen Sie zunächst beim Hersteller der eingesetzten Software, ob Ihre Software-Version und zusätzlich installierte Komponenten, Module oder Plugins, mit den neueren PHP-Versionen (5.6 oder höher) kompatibel ist.

Meine Webseite ist leider nicht mit einer höheren Version von PHP kompatibel. Was kann ich tun?

Falls die von Ihnen eingesetzte Software nicht mit den neueren PHP-Versionen (5.6 oder höher) kompatibel ist, prüfen Sie bitte, ob es eine neuere Version Ihrer Software gibt, welche die aktuellen PHP-Versionen unterstützt. Setzen Sie sich hierzu ggf. mit Ihrem Webmaster oder Ihrer Agentur in Verbindung.

Bitte haben Sie jedoch Verständnis dafür, dass wir Sie bei eventuell notwendigen Anpassungen von Skripten nicht unterstützen können.

Was passiert wenn ich nicht rechtzeitig auf eine aktuellere PHP-Version umstelle?

Alle Webseiten, die zum “01.01.2019“ noch nicht umgestellt wurden, werden von uns automatisch auf die PHP-Version 5.6 umgestellt. Um Ausfälle zu vermeiden, sollten Sie unbedingt aktiv werden.